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Pairing and Connectivitiy Issues

Resolving Bluetooth connectivity issues between Liberty/Freedom and Divesoft App

Problem description:
The CCR Liberty or Freedom may fail to connect or pair with the DivesoftApp or Divesoft Center. Symptoms include pairing errors, unstable Bluetooth Low Energy (BLE) communication, or missing serial numbers from Control Units (CUs).

Possible causes:

  • Outdated firmware.
  • BLE communication errors caused by software bugs.
  • Device missing serial number.

Step-by-step troubleshooting:

  • Update the device to the latest firmware. New releases often resolve Bluetooth issues. Use USB if you cannot connect using Bluetooth.
  • Remove existing Liberty/Freedom pairings on your phone/computer and restart both devices before re-pairing.
  • Make sure the device is no further than 2 meters (6 feet) and avoid Wi-Fi interference when testing.
  • Try using a different phone or computer to rule out issues with your original device.
  • All Divesoft devices are paired/added directly using the DivesoftApp, do not attempt to pair the Freedom/Liberty using the Android/Apple system prompt.
  • If your device is missing its serial numbers (see the System Check) then contact Divesoft Support, this condition can be resolved remotely without shipping the device for service.